summaryrefslogtreecommitdiff
path: root/linux.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2019-04-15 09:18:13 -0700
committerBen Sima <ben@bsima.me>2019-04-15 09:18:13 -0700
commitd5cebe7cc360b3bc17421cb9cb2b5230471b08ab (patch)
tree8aa5ca63fae582336515a5adad7dad8471f1da05 /linux.nix
parent0fc3628e305b0f548bfa0fcf5c86bd59c57a46d9 (diff)
xmonad: fix light background color
Diffstat (limited to 'linux.nix')
-rw-r--r--linux.nix14
1 files changed, 10 insertions, 4 deletions
diff --git a/linux.nix b/linux.nix
index f712844..4ca0afb 100644
--- a/linux.nix
+++ b/linux.nix
@@ -7,14 +7,14 @@ let
(builtins.readFile "${homedir}/.local/share/xtheme");
colors = {
"dark" = {
+ highlight = "#5d4d7a";
background = "#292b2e";
foreground = "#b2b2b2";
- highlight = "#5d4d7a";
};
"light" = {
+ highlight = "#67b11d";
background = "#fbf8ef";
foreground = "#655370";
- highlight = "#67b11d";
};
};
in
@@ -31,6 +31,12 @@ in
"XTerm*termName" = "xterm-256color";
"XTerm*metaSendsEscape" = true;
"XTerm*utf8" = true;
+ #"Xautolock.time:" = 1;
+ #"Xautolock.locker:" = "xlock";
+ #"Xautolock.corners:" = "+0-0";
+ #"Xautolock.cornerdelay:" = 3;
+ #"Xautolock.notify:" = 30;
+ #"Xautolock.notifier:" = "notify-send -u critical -t 10000 -- 'Locking screen in 30 seconds'";
};
extraConfig = builtins.readFile(solarized-xresources + "/Xresources." + theme);
};
@@ -150,8 +156,8 @@ in
latitude = "33.044444";
longitude = "-117.271667";
temperature = {
- day = 4000;
- night = 3500;
+ day = 6000;
+ night = 2500;
};
};