summaryrefslogtreecommitdiff
path: root/linux.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2018-11-14 14:42:20 -0800
committerBen Sima <ben@bsima.me>2018-11-14 14:44:59 -0800
commitee66111ba1ff1bb5e74fd836aa883204e59b0310 (patch)
treeeab2965ffc3617934d87f9bf0f8a591a72445739 /linux.nix
parent7ad40c1d4bc81e82ffd808dc538756fd29cddd54 (diff)
Split into os-specific files
Diffstat (limited to 'linux.nix')
-rw-r--r--linux.nix114
1 files changed, 114 insertions, 0 deletions
diff --git a/linux.nix b/linux.nix
index 516d8e1..c90f7f1 100644
--- a/linux.nix
+++ b/linux.nix
@@ -1,5 +1,119 @@
{ pkgs, ... }:
+let
+ solarized-xresources = ./xresources;
+in
{
imports = [ ./common.nix ];
+ fonts.fontconfig.enableProfileFonts = true;
+
+ xresources = {
+ properties = {
+ "XTerm*font" = "*-fixed-*-*-*-*-*";
+ "XTerm*faceName" = "mononoki";
+ "XTerm*faceSize" = "10";
+ "XTerm*termName" = "xterm-256color";
+ "XTerm*metaSendsEscape" = true;
+ };
+ extraConfig = builtins.readFile(solarized-xresources + "/Xresources.dark");
+ };
+
+ services = {
+ network-manager-applet.enable = false;
+
+ polybar = {
+ enable = false;
+ config = {
+ "bar/top" = {
+ font-0 = "mononoki:size-10";
+ monitor = "\${env:MONITOR:eDP1}";
+ monitor-fallback = "HDMI1";
+ width = "100%";
+ height = "2%";
+ radius = 0;
+ background = "#fdf6e3"; # solarized base3
+ foreground = "#657b83"; # solarized base00
+ tray-position = "right";
+ tray-detached = false;
+ tray-maxsize = 16;
+ tray-transparent = false;
+ tray-background = "#fdf6e3";
+ tray-offset-x = 0;
+ tray-offset-y = 0;
+ tray-padding = 0;
+ tray-scale = 1.0;
+ module-margin = 4;
+ modules-center = "date";
+ modules-right = "battery";
+ };
+ "module/date" = {
+ type = "internal/date";
+ internal = 5;
+ date = "%Y.%m.%d";
+ time = "%H.%M";
+ label = "%date%..%time%";
+ };
+ "module/battery" = {
+ type = "internal/battery";
+ battery = "BAT0";
+ adapter = "AC";
+ full-at = 99;
+ };
+ "module/ewmh" = {
+ type = "internal/xworkspaces";
+ pin-workspaces = true;
+ enable-click = true;
+ enable-scroll = false;
+ };
+ };
+ script = ''
+ #!/usr/bin/env sh
+ systemctl --user daemon-reload
+ polybar top &
+ '';
+ };
+
+ taffybar = {
+ enable = false;
+ };
+
+ redshift = {
+ enable = false;
+ latitude = "33.044444";
+ longitude = "-117.271667";
+ };
+
+ gpg-agent = {
+ enable = true;
+ defaultCacheTtl = 600;
+ enableSshSupport = true;
+ extraConfig = ''
+ allow-emacs-pinentry
+ pinentry-program /home/ben/.nix-profile/bin/pinentry-tty
+ '';
+ };
+ };
+
+ xsession = {
+ enable = false;
+ windowManager = {
+ xmonad = {
+ enable = false;
+ extraPackages = hpkgs: [
+ hpkgs.xmonad-contrib
+ hpkgs.xmonad-extras
+ hpkgs.monad-logger
+ hpkgs.taffybar
+ ];
+ enableContribAndExtras = true;
+ config = ./xmonad.hs;
+ };
+ };
+ };
+
+ programs = {
+ firefox = {
+ enable = true;
+ };
+ };
}