summaryrefslogtreecommitdiff
path: root/machines/helium.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2022-12-16 16:25:27 -0500
committerBen Sima <ben@bsima.me>2022-12-16 16:25:27 -0500
commit0858e7a3a39ddd2deae128f513fbdedd9edff1b9 (patch)
treefcf2f65c5579e32c40a8b6f868128ab46bac2bbe /machines/helium.nix
parentd1cc16ccafa8e4230226efd20a5ae5d373bac305 (diff)
parent77d7f79048484266bddde2ce9405d10411a8a1d7 (diff)
Merge remote-tracking branch 'origin/master'
Diffstat (limited to 'machines/helium.nix')
-rw-r--r--machines/helium.nix17
1 files changed, 15 insertions, 2 deletions
diff --git a/machines/helium.nix b/machines/helium.nix
index d2a054f..093b25d 100644
--- a/machines/helium.nix
+++ b/machines/helium.nix
@@ -7,6 +7,8 @@ let
in {
imports = [ ./users.nix ];
+ console.font = "${pkgs.fira-mono}/share/fonts/opentype/FiraMono-Regular.otf";
+
security.sudo.wheelNeedsPassword = true;
security.pam.yubico.enable = true;
security.pam.yubico.debug = false;
@@ -60,6 +62,7 @@ in {
};
};
+ hardware.video.hidpi.enable = true;
hardware.enableAllFirmware = true;
hardware.bluetooth.enable = true;
hardware.bluetooth.package = pkgs.bluezFull;
@@ -103,13 +106,19 @@ in {
xserver.autorun = true;
xserver.layout = "us";
xserver.libinput.enable = true;
+ xserver.libinput.mouse.additionalOptions = ''
+ Option "ScrollMethod" "Button"
+ Option "ScrollButton" "3"
+ '';
+ xserver.libinput.mouse.buttonMapping = "1 2 8 4 5 6 7 3 9";
xserver.xkbOptions = "caps:ctrl_modifier";
+ xserver.dpi = 331;
xserver.displayManager.sddm.enable = true;
xserver.windowManager.xmonad.enable = true;
xserver.desktopManager.xterm.enable = true;
- xserver.xautolock.enable = true;
+ xserver.xautolock.enable = false;
xserver.xautolock.locker = "${pkgs.xlockmore}/bin/xlock -mode matrix";
xserver.xautolock.nowlocker = "${pkgs.xlockmore}/bin/xlock -mode matrix"; # xautolock -locknow
xserver.xautolock.time = 5; # minutes
@@ -144,7 +153,7 @@ in {
};
systemd.services = {
"xlock" = {
- enable = true;
+ enable = false;
script = "xlock";
path = [ pkgs.xlockmore ];
# nat sure about these targets
@@ -183,6 +192,10 @@ in {
sshUser = "ben";
sshKey = "/home/ben/.ssh/id_rsa";
system = "x86_64-linux";
+ supportedFeatures = [
+ "x86_64-linux"
+ "big-parallel"
+ ];
}
];
nix.distributedBuilds = true;