summaryrefslogtreecommitdiff
path: root/packages.nix
diff options
context:
space:
mode:
authorBen Sima <bsima@groq.com>2019-06-11 13:37:25 -0700
committerBen Sima <ben@bsima.me>2019-07-09 15:49:50 -0700
commit0176935d1d53b71555b4809d08b1195fe80c4b2e (patch)
tree97a823a76e3a32bb5663b1a0056ffd84d123bf1c /packages.nix
parentfc1329fc2fa4d94f5881d7079c0190d28b0796ce (diff)
refactor for and setup groq machine
Diffstat (limited to 'packages.nix')
-rw-r--r--packages.nix43
1 files changed, 5 insertions, 38 deletions
diff --git a/packages.nix b/packages.nix
index 37552e0..28e70a1 100644
--- a/packages.nix
+++ b/packages.nix
@@ -3,25 +3,7 @@
# All common packages go here. Linux-specific should go in `linux.nix'
with pkgs;
-let
- cmdtree = stdenv.mkDerivation {
- name = "cmdtree";
- src = fetchGit {
- url = "https://git.sr.ht/~jb55/cmdtree";
- ref = "master";
- rev = "5606078e8fa02462f0208d9f9cad98c7673812e6";
- };
- buildPhase = ''
- cp ${./cfg.def.h} ./cfg.def.h
- make
- '';
- installPhase = ''
- mkdir -p $out/bin
- cp ./cmdtree $out/bin
- '';
- buildInputs = [ pkgs.xorg.libX11 pkgs.xorg.libXft ];
- };
-in
+
[
ag
aspellDicts.en
@@ -35,11 +17,9 @@ dhall
dict
dmenu
dolphin
+cloc
entr
-exercism
expect
-fasd
-feh
file
flameshot
font-awesome_5
@@ -52,8 +32,6 @@ hledger-web
htop
ispell
jq
-ledger
-libnotify
lshw
lsof
material-icons
@@ -63,10 +41,7 @@ mplayer
msmtp
muchsync
ncdu
-neomutt
nix-prefetch-scripts
-obs-studio
-pandoc
pass
pasystray
pdftk
@@ -80,6 +55,9 @@ tdesktop
terminus
#texlive.combined.scheme-full
tmux
+ranger
+ripgrep
+shellcheck
tree
unrar
unzip
@@ -93,15 +71,4 @@ yank
youtube-dl
zathura
zip
-zoom-us
-
-# languages i regularly use
-clojure
-ghc
-guile
-ocaml
-python3
-lispPackages.quicklisp
-sbcl
-
]