summaryrefslogtreecommitdiff
path: root/pkgs/hledger-lib-1.19.1.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2021-01-03 10:15:50 -0500
committerBen Sima <ben@bsima.me>2021-01-03 10:16:05 -0500
commitc01347729161e7b358fd4bee63c62feb150feb5e (patch)
treeb3ae4137fe345d11bc3f0d27c0a34b3eb65e8f63 /pkgs/hledger-lib-1.19.1.nix
parent8f786888424aad4e5462c17f99e70394bea17732 (diff)
update hledger
Diffstat (limited to 'pkgs/hledger-lib-1.19.1.nix')
-rw-r--r--pkgs/hledger-lib-1.19.1.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/pkgs/hledger-lib-1.19.1.nix b/pkgs/hledger-lib-1.19.1.nix
new file mode 100644
index 0000000..329bade
--- /dev/null
+++ b/pkgs/hledger-lib-1.19.1.nix
@@ -0,0 +1,35 @@
+{ mkDerivation, aeson, aeson-pretty, ansi-terminal, array, base
+, base-compat-batteries, blaze-markup, bytestring, call-stack
+, cassava, cassava-megaparsec, cmdargs, containers, data-default
+, Decimal, directory, doctest, extra, fgl, file-embed, filepath
+, Glob, hashtables, megaparsec, mtl, old-time, parsec
+, parser-combinators, pretty-show, regex-tdfa, safe, split, stdenv
+, tabular, tasty, tasty-hunit, template-haskell, text, time, timeit
+, transformers, uglymemo, unordered-containers, utf8-string
+}:
+mkDerivation {
+ pname = "hledger-lib";
+ version = "1.19.1";
+ sha256 = "cabf263fe8a3c38822c9146b54a519fe56d369456c72be6db5a88c1c0208c15f";
+ libraryHaskellDepends = [
+ aeson aeson-pretty ansi-terminal array base base-compat-batteries
+ blaze-markup bytestring call-stack cassava cassava-megaparsec
+ cmdargs containers data-default Decimal directory extra fgl
+ file-embed filepath Glob hashtables megaparsec mtl old-time parsec
+ parser-combinators pretty-show regex-tdfa safe split tabular tasty
+ tasty-hunit template-haskell text time timeit transformers uglymemo
+ unordered-containers utf8-string
+ ];
+ testHaskellDepends = [
+ aeson aeson-pretty ansi-terminal array base base-compat-batteries
+ blaze-markup bytestring call-stack cassava cassava-megaparsec
+ cmdargs containers data-default Decimal directory doctest extra fgl
+ file-embed filepath Glob hashtables megaparsec mtl old-time parsec
+ parser-combinators pretty-show regex-tdfa safe split tabular tasty
+ tasty-hunit template-haskell text time timeit transformers uglymemo
+ unordered-containers utf8-string
+ ];
+ homepage = "http://hledger.org";
+ description = "A reusable library providing the core functionality of hledger";
+ license = stdenv.lib.licenses.gpl3;
+}