summaryrefslogtreecommitdiff
path: root/profiles/workshop.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2021-05-16 09:49:15 -0400
committerBen Sima <ben@bsima.me>2021-05-16 09:49:15 -0400
commitfa8a6f493f1b5060fa306e39a5502df56f4f02c1 (patch)
treee1dbd7a4dbd9acb48e4745527de3927ba6880244 /profiles/workshop.nix
parentd2b49d5dda113d42a4d221be36ee3298c43350d3 (diff)
move stuff into profiles
Diffstat (limited to 'profiles/workshop.nix')
-rw-r--r--profiles/workshop.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/profiles/workshop.nix b/profiles/workshop.nix
new file mode 100644
index 0000000..b4cf4c1
--- /dev/null
+++ b/profiles/workshop.nix
@@ -0,0 +1,16 @@
+# lithium server
+{ pkgs, lib, ... }:
+
+{
+ imports = [
+ ../lib/linux.nix
+ ];
+ programs.git.signing.signByDefault = true;
+ systemd.user.services = {
+ "shop-music".Service = {
+ RestartSec = "3s";
+ Restart = "always";
+ ExecStart = "${pkgs.mplayer}/bin/mplayer http://localhost:8097";
+ };
+ };
+}