summaryrefslogtreecommitdiff
path: root/vim.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2018-05-29 13:47:43 -0700
committerBen Sima <ben@bsima.me>2018-05-29 13:47:43 -0700
commit0c419f10b3e90f8f2d10898e025a778801e406ae (patch)
tree86d7deec606ab52ce5cc5754d8b4ccae283207d9 /vim.nix
parent17294eb0bf1b4dc6e65543c1c2c629968bf394ba (diff)
Fixup stuff for laptop
Diffstat (limited to 'vim.nix')
-rw-r--r--vim.nix11
1 files changed, 3 insertions, 8 deletions
diff --git a/vim.nix b/vim.nix
index aeabaef..80954c7 100644
--- a/vim.nix
+++ b/vim.nix
@@ -1,6 +1,7 @@
{
enable = true;
plugins = [
+ "sensible"
"colors-solarized"
"fugitive"
];
@@ -18,26 +19,20 @@
else
set background=dark
endif
+ let g:solarized_termcolors=256
colorscheme solarized
- filetype plugin indent on
+ "
set cuc cul " Crosshair
set cc=80 " 80 column lines
set linebreak " Break lines at word (requires Wrap lines)
- set showbreak= " Wrap-broken line prefix
set textwidth=80 " Line wrap (number of cols)
set showmatch " Highlight matching brace
set visualbell " Use visual bell (no beeping)
set hlsearch " Highlight all search results
set smartcase " Enable smart-case search
- set incsearch " Searches for strings incrementally
- ret autoindent " Auto-indent new lines
set shiftwidth=4 " Number of auto-indent spaces
set smartindent " Enable smart-indent
- set smarttab " Enable smart-tabs
- set ruler " Show row and column ruler information
- set backspace=indent,eol,start " Backspace behaviour
imap fd <Esc>
- set wildmenu " cool menu effect
set mouse=a
'';
}