summaryrefslogtreecommitdiff
path: root/vim.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2018-05-21 16:44:47 -0700
committerBen Sima <ben@bsima.me>2018-05-21 16:44:47 -0700
commit10af53f0094ccc74d818dc2fff101363e3da0995 (patch)
treee522ec2799740373126db62b78daf3daa0d97efc /vim.nix
parent6e536c4a6966b5b8c6508191d79e9574d4df44bf (diff)
Reorganize stuff into files
Diffstat (limited to 'vim.nix')
-rw-r--r--vim.nix43
1 files changed, 43 insertions, 0 deletions
diff --git a/vim.nix b/vim.nix
new file mode 100644
index 0000000..dbb1a9c
--- /dev/null
+++ b/vim.nix
@@ -0,0 +1,43 @@
+{
+ enable = true;
+ plugins = [
+ "colors-solarized"
+ "fugitive"
+ ];
+ settings = {
+ ignorecase = true;
+ expandtab = true;
+ history = 1000;
+ tabstop = 4;
+ };
+ extraConfig = ''
+ " Auto-switch theme
+ let hour = strftime("%H")
+ if 6 <= hour && hour < 18
+ set background=light
+ else
+ set background=dark
+ endif
+ colorscheme solarized
+ filetype plugin indent on
+ set cuc cul " Crosshair
+ set cc=80 " 80 column lines
+ set linebreak " Break lines at word (requires Wrap lines)
+ set showbreak= " Wrap-broken line prefix
+ set textwidth=80 " Line wrap (number of cols)
+ set showmatch " Highlight matching brace
+ set visualbell " Use visual bell (no beeping)
+ set hlsearch " Highlight all search results
+ set smartcase " Enable smart-case search
+ set incsearch " Searches for strings incrementally
+ ret autoindent " Auto-indent new lines
+ set shiftwidth=4 " Number of auto-indent spaces
+ set smartindent " Enable smart-indent
+ set smarttab " Enable smart-tabs
+ set ruler " Show row and column ruler information
+ set backspace=indent,eol,start " Backspace behaviour
+ imap fd <Esc>
+ set wildmenu " cool menu effect
+ set mouse=a
+ '';
+}