summaryrefslogtreecommitdiff
path: root/vim.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2018-06-26 10:52:57 -0700
committerBen Sima <ben@bsima.me>2018-06-26 10:52:57 -0700
commit6f0ad262663852dbbd6b0a132733b12dce6c8c50 (patch)
tree61fab83ff0c6c7425ea75a6c4b351ccff58f1e27 /vim.nix
parentcecf40211dc22f18abbd46fd8397c2570c7b7acd (diff)
Add ctags, netrw browser, and status line changes
Diffstat (limited to 'vim.nix')
-rw-r--r--vim.nix11
1 files changed, 9 insertions, 2 deletions
diff --git a/vim.nix b/vim.nix
index 2c39fa1..b5af63a 100644
--- a/vim.nix
+++ b/vim.nix
@@ -1,4 +1,4 @@
-{ pkgs, vimUtils, fetchFromGitHub }:
+{ pkgs, vimUtils, fetchFromGitHub}:
let
vim-sexp = vimUtils.buildVimPluginFrom2Nix {
@@ -37,9 +37,16 @@ in
set smartcase " Enable smart-case search
set shiftwidth=4 " Number of auto-indent spaces
set smartindent " Enable smart-indent
+ set laststatus=1 " No status line
imap fd <Esc>
+ let g:netrw_banner=0 " Disable file browser banner
+ let g:netrw_liststyle=3 " Tree view
set mouse=a
- ""
+ "" CTAGS shortcuts
+ "" open definition in a new tab:
+ map <C-\> :tab split<CR>:exec("tag ".expand("<cword>"))<CR>
+ "" open definition in a vertical split:
+ map <A-]> :vsp <CR>:exec("tag ".expand("<cword>"))<CR>
"" https://github.com/lifepillar/vim-solarized8#troubleshooting
let &t_8f = "\<Esc>[38:2:%lu:%lu:%lum"
let &t_8b = "\<Esc>[48:2:%lu:%lu:%lum"