summaryrefslogtreecommitdiff
path: root/vim.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2018-08-21 09:58:46 -0700
committerBen Sima <ben@bsima.me>2018-08-21 09:58:46 -0700
commitb103278402322fc0af88aba812693f92af316027 (patch)
tree68ef60db010f4340d928d0140cc4a4ed59e5af0f /vim.nix
parentf096799004a8549f61dcc1b289d8aa79ee7ea6bd (diff)
Remove sensible and move to vimrc file
Diffstat (limited to 'vim.nix')
-rw-r--r--vim.nix33
1 files changed, 1 insertions, 32 deletions
diff --git a/vim.nix b/vim.nix
index 356e901..ddc0b5a 100644
--- a/vim.nix
+++ b/vim.nix
@@ -3,7 +3,6 @@
{
enable = true;
plugins = [
- "sensible"
"ctrlp"
"fugitive"
"editorconfig-vim"
@@ -16,35 +15,5 @@
history = 1000;
tabstop = 4;
};
- extraConfig = ''
- set cc=80 " 80 column lines
- set linebreak " Break lines at word (requires Wrap lines)
- set textwidth=80 " Line wrap (number of cols)
- set showmatch " Highlight matching brace
- set visualbell " Use visual bell (no beeping)
- set hlsearch " Highlight all search results
- set smartcase " Enable smart-case search
- set shiftwidth=4 " Number of auto-indent spaces
- set smartindent " Enable smart-indent
- set laststatus=1 " No status line
-
- " Mappings
- imap fd <Esc>
- nnoremap ,s :r ~/sig.txt<cr>
-
- " Easily find cursor with crosshair (\c)
- :hi CursorLine cterm=NONE term=reverse ctermbg=7 guibg=Grey90
- :hi CursorColumn cterm=NONE term=reverse ctermbg=7 guibg=Grey90
- :nnoremap <Leader>c :set cursorline! cursorcolumn!<CR>
-
- " File browser
- let g:netrw_banner=0 " Disable file browser banner
- let g:netrw_liststyle=3 " Tree view
-
- "" CTAGS shortcuts
- " open definition in a new tab:
- map <C-\> :tab split<CR>:exec("tag ".expand("<cword>"))<CR>
- " open definition in a vertical split:
- map <A-]> :vsp <CR>:exec("tag ".expand("<cword>"))<CR>
- '';
+ extraConfig = builtins.readFile ./vimrc;
}