summaryrefslogtreecommitdiff
path: root/vim.nix
diff options
context:
space:
mode:
authorBen Sima <bsima@groq.com>2019-06-11 13:40:01 -0700
committerBen Sima <ben@bsima.me>2019-07-09 15:49:50 -0700
commitf2bce08b9412b0b50d3d7af8dff7903b40f13bff (patch)
tree39a89bcfd1767db030dea40d56e89ccf9ced411c /vim.nix
parent0176935d1d53b71555b4809d08b1195fe80c4b2e (diff)
migrate vim to use home-manager settings
Diffstat (limited to 'vim.nix')
-rw-r--r--vim.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/vim.nix b/vim.nix
new file mode 100644
index 0000000..57f79ba
--- /dev/null
+++ b/vim.nix
@@ -0,0 +1,16 @@
+{ ... }:
+
+{
+ programs.vim = {
+ enable = true;
+ plugins = [
+ "ctrlp"
+ "fugitive"
+ "editorconfig-vim"
+ "surround"
+ "vim-colorschemes"
+ "vim-ripgrep"
+ ];
+ extraConfig = builtins.readFile ../vimrc;
+ };
+}