summaryrefslogtreecommitdiff
path: root/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common.nix')
-rw-r--r--common.nix16
1 files changed, 12 insertions, 4 deletions
diff --git a/common.nix b/common.nix
index eec499a..d23b238 100644
--- a/common.nix
+++ b/common.nix
@@ -32,10 +32,6 @@ in
source = ./mailcap;
target = ".mailcap";
};
- tmux = {
- source = ./tmux;
- target = ".tmux.conf";
- };
};
};
@@ -45,6 +41,18 @@ in
path = "${homedir}/cfg/home-manager";
};
+ tmux = {
+ enable = true;
+ extraConfig = builtins.readFile ./tmux;
+ baseIndex = 0;
+ clock24 = true;
+ customPaneNavigationAndResize = true;
+ keyMode = "vi";
+ shortcut = "'C-\\'";
+ terminal = "screen-256color";
+ sensibleOnTop = true;
+ };
+
ssh = {
enable = true;
forwardAgent = true;