summaryrefslogtreecommitdiff
path: root/darwin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'darwin.nix')
-rw-r--r--darwin.nix17
1 files changed, 14 insertions, 3 deletions
diff --git a/darwin.nix b/darwin.nix
index d91c25e..c278623 100644
--- a/darwin.nix
+++ b/darwin.nix
@@ -6,8 +6,20 @@ let
gpgid = "D09299626FA78AF8";
in
{
- imports = [ ./lib/common.nix ];
- home.sessionVariables.PATH = "/usr/local/opt/mysql@5.7/bin:${homedir}/bin:${homedir}/.cabal/bin:${homedir}/.local/bin:$PATH";
+ imports = [
+ ./lib/common.nix
+ ./lib/email.nix
+ ];
+ home = {
+ sessionVariables.PATH = "/usr/local/opt/mysql@5.7/bin:${homedir}/bin:${homedir}/.cabal/bin:${homedir}/.local/bin:$PATH";
+ packages = with pkgs; [
+ muchsync
+ hledger-web
+ hledger-ui
+ (haskellPackages.ghcWithPackages (ps: with ps; [hledger]))
+ ];
+ };
+
programs = {
git = {
@@ -43,6 +55,5 @@ in
enable = true;
extraPackages = epkgs: import ./lib/emacs-packages.nix { inherit epkgs; };
};
-
};
}