summaryrefslogtreecommitdiff
path: root/darwin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'darwin.nix')
-rw-r--r--darwin.nix37
1 files changed, 1 insertions, 36 deletions
diff --git a/darwin.nix b/darwin.nix
index 4dc9676..c221e9e 100644
--- a/darwin.nix
+++ b/darwin.nix
@@ -2,8 +2,6 @@
let
homedir = builtins.getEnv "HOME";
- gitCommitTemplate = ./lib/git-commit-template;
- gpgid = "D09299626FA78AF8";
haskellOverlay = self: super: {
haskellPackages = super.haskellPackages.override (old: {
overrides = self: super: {
@@ -33,35 +31,6 @@ in
programs = {
- git = {
- enable = true;
- userName = "Ben Sima";
- userEmail = "ben@bsima.me";
- ignores = [ "*~" "*.swp" ];
- package = pkgs.gitAndTools.gitFull;
- signing = {
- key = gpgid;
- signByDefault = false;
- };
- aliases = {
- authors = "shortlog -s -n";
- };
- extraConfig = ''
- [push]
- default = simple
-
- [commit]
- template = ${gitCommitTemplate}
-
- [sendemail]
- smtpuser = ben@bsima.me
- smptserverport = 587
- smptserver = mail.bsima.me
- chainreplyto = false
- composeencoding = UTF-8
- '';
- };
-
# Doesnt' work bc clang can't compile it??
#qutebrowser = {
# enable = true;
@@ -70,9 +39,5 @@ in
# };
#};
- emacs = {
- enable = true;
- extraPackages = epkgs: import ./lib/emacs-packages.nix { inherit epkgs; };
- };
- };
+ };
}