summaryrefslogtreecommitdiff
path: root/groq.nix
diff options
context:
space:
mode:
Diffstat (limited to 'groq.nix')
-rw-r--r--groq.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/groq.nix b/groq.nix
new file mode 100644
index 0000000..f30d188
--- /dev/null
+++ b/groq.nix
@@ -0,0 +1,32 @@
+{ pkgs, ... }:
+
+let
+ gitCommitTemplate = ./git-commit-template;
+in
+{
+ imports = [
+ ./common.nix
+ ];
+ programs = {
+ emacs = {
+ enable = true;
+ extraPackages = epkgs: import ./emacs-packages.nix { inherit epkgs; };
+ };
+
+ git = {
+ enable = true;
+ userName = "Ben Sima";
+ userEmail = "bsima@groq.com";
+ ignores = [ "*~" "*.swp" ];
+ package = pkgs.gitAndTools.gitFull;
+ extraConfig = ''
+ [push]
+ default = simple
+
+ [commit]
+ template = ${gitCommitTemplate}
+ '';
+ };
+
+ };
+}