summaryrefslogtreecommitdiff
path: root/lib/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/common.nix')
-rw-r--r--lib/common.nix78
1 files changed, 5 insertions, 73 deletions
diff --git a/lib/common.nix b/lib/common.nix
index b51d3fe..011e7e7 100644
--- a/lib/common.nix
+++ b/lib/common.nix
@@ -7,7 +7,6 @@ let
in
{
home = {
- packages = import ./packages.nix { inherit pkgs; };
sessionVariables = {
GPGID = gpgid;
EDITOR = "vim";
@@ -148,7 +147,11 @@ in
for f in extrakto.sh open.sh tmux-extrakto.sh; do
wrapProgram $target/scripts/$f \
--prefix PATH : ${with pkgs; lib.makeBinPath (
- [pkgs.fzf pkgs.python3 pkgs.xclip]
+ [
+ pkgs.fzf
+ pkgs.python3
+ pkgs.xclip
+ ]
)}
done
'';
@@ -202,72 +205,6 @@ in
#shading = 10;
};
- ssh = {
- enable = true;
- forwardAgent = true;
- extraConfig = ''
- StrictHostKeyChecking=accept-new
-
- # sft ssh-config
- Match exec "/usr/local/bin/sft resolve -q %h"
- ProxyCommand "/usr/local/bin/sft" proxycommand %h
- UserKnownHostsFile "/Users/bsima/Library/Application Support/ScaleFT/proxycommand_known_hosts"
- '';
- matchBlocks = {
- "github.com" = {
- hostname = "github.com";
- user = "git";
- identityFile = [ "${homedir}/.ssh/id_rsa" ];
- identitiesOnly = true;
- };
-
- # groq
- "groq" = {
- hostname = "bsima"; # must be on vpn
- user = "bsima";
- identityFile = [ "${homedir}/.ssh/groq" ];
- identitiesOnly = true;
- };
-
- # simatime
- "sabten" = {
- hostname = "142.93.81.26";
- user = "root";
- identityFile = [ "${homedir}/.ssh/id_rsa" ];
- identitiesOnly = true;
- };
- "serval.simatime.com" = {
- hostname = "serval.simatime.com";
- user = "ben";
- identityFile = [ "${homedir}/.ssh/id_rsa" ];
- identitiesOnly = true;
- };
- "simatime.com" = {
- hostname = "simatime.com";
- user = "git";
- identityFile = [ "${homedir}/.ssh/id_rsa" ];
- identitiesOnly = true;
- };
- "lithium" = {
- hostname = "192.168.1.9";
- user = "ben";
- identityFile = [ "${homedir}/.ssh/id_rsa" ];
- identitiesOnly = true;
- };
- "dev.simatime.com" = {
- user = "ben";
- identityFile = [ "${homedir}/.ssh/id_rsa" ];
- identitiesOnly = true;
- };
- "git.platonic.systems" = {
- hostname = "git.platonic.systems";
- user = "git";
- identityFile = [ "${homedir}/.ssh/platonic.systems" ];
- identitiesOnly = true;
- };
- };
- };
-
direnv = {
enable = true;
};
@@ -420,10 +357,5 @@ in
"v." = "vim .";
};
};
-
- emacs = {
- enable = true;
- extraPackages = epkgs: import ./emacs-packages.nix { inherit epkgs; };
- };
};
}