summaryrefslogtreecommitdiff
path: root/lib/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/common.nix')
-rw-r--r--lib/common.nix17
1 files changed, 15 insertions, 2 deletions
diff --git a/lib/common.nix b/lib/common.nix
index d4eadc3..70995f9 100644
--- a/lib/common.nix
+++ b/lib/common.nix
@@ -84,6 +84,16 @@ in
package = pkgs.gitAndTools.gitFull;
signing = {
key = gpgid;
+ # for some reason this fails...
+ #gpgPath =
+ # let
+ # script = pkgs.writeScriptBin "my-ots-git-gpg-wrapper" ''
+ # #!/usr/bin/env bash
+ # set -euxo pipefail
+ # ${pkgs.opentimestamps-client}/bin/ots-git-gpg-wrapper --gpg-program ${pkgs.gnupg}/bin/gpg $@
+ # '';
+ # in
+ # "${script}/bin/my-ots-git-gpg-wrapper";
};
aliases = {
authors = "shortlog -s -n";
@@ -102,7 +112,10 @@ in
composeencoding = "UTF-8";
annotate = "yes";
};
- log.date = "local";
+ log = {
+ date = "local";
+ showSignature = true;
+ };
};
};
@@ -347,7 +360,7 @@ in
gl = "git pull --prune";
gp = "git push origin HEAD";
gs = "git status -sb";
- hs = "home-manager switch";
+ hs = "NIX_PATH=$HOME/.nix-defexpr/channels$\{NIX_PATH:+:\}$NIX_PATH home-manager switch";
ll = "ls -lah";
rm = "rm -i";
s = ''