summaryrefslogtreecommitdiff
path: root/lib/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/common.nix')
-rw-r--r--lib/common.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/lib/common.nix b/lib/common.nix
index ff7edd6..7d5f520 100644
--- a/lib/common.nix
+++ b/lib/common.nix
@@ -70,6 +70,32 @@ in {
enable = true;
};
+ readline = {
+ enable = true;
+ variables = {
+ keyseq-timeout = 1200;
+ colored-stats = true;
+ colored-completion-prefix = true;
+ expand-tilde = true;
+ };
+ bindings = {
+ # wrap a command in '$(...| fzf)'
+ "\\C-xf" = ''"\C-e | fzf)\C-a(\C-a$\C-b\C-a"'';
+ "\\e\\C-f" = "dump-functions"; # help
+ "\\e\\C-o" = "dabbrev-expand"; # expand
+ "\\e\\C-v" = "dump-variables"; # help
+ "\\em" = "beginning-of-line";
+ # emacs-like history navigation
+ "\\en" = "next-history";
+ "\\ep" = "previous-history";
+ };
+ extraConfig = ''
+ $if Guile
+ "\C-o": "()\C-b"
+ $endif
+ '';
+ };
+
fzf = {
enable = true;
enableBashIntegration = true;