summaryrefslogtreecommitdiff
path: root/lib/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/common.nix')
-rw-r--r--lib/common.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/lib/common.nix b/lib/common.nix
index a87ebb5..aafb1dc 100644
--- a/lib/common.nix
+++ b/lib/common.nix
@@ -115,6 +115,8 @@ in
pull.rebase = "true";
commit.template = "${./git-commit-template}";
commit.verbose = "true";
+ mergetool.fugitive.cmd = ''vim -f -c "Gvdiffsplit!" "$MERGED"'';
+ merge.tool = "fugitive";
sendemail = {
#smtpuser = "ben@bsima.me";
#smtpserverport = 587;
@@ -229,6 +231,7 @@ in
plugins = with pkgs.vimPlugins; [
editorconfig-vim
vim-sensible
+ vim-fugitive
vim-colorschemes
vim-sexp-mappings-for-regular-people
# vim-ripgrep # not in nixpkgs :(