summaryrefslogtreecommitdiff
path: root/lib/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/common.nix')
-rw-r--r--lib/common.nix28
1 files changed, 13 insertions, 15 deletions
diff --git a/lib/common.nix b/lib/common.nix
index 110381d..f482bc6 100644
--- a/lib/common.nix
+++ b/lib/common.nix
@@ -244,18 +244,16 @@ in {
urxvt = let font = size: "xft:Fira Mono:size=${toString size}:ant"; in {
enable = true;
fonts = [
- # for some reason, urxvt font size is much larger than every other
- # program's, so i gotta cut it in half
(font (fontSize / 2))
"xft:Noto Emoji"
];
- keybindings = {
- # why don't any of these work?
- "Shift-Control-C" = "eval:selection_to_clipboard";
- "Shift-Control-V" = "eval:paste_clipboard";
- "Shift-Control-+" = "command:\033]710;${font 12}\007\033]711;${font 12}\007";
- "Shift-Control--" = "command:\033]710;${font 8}\007\033]711;${font 8}\007";
- };
+ #keybindings = {
+ # # why don't any of these work?
+ # "Shift-Control-C" = "eval:selection_to_clipboard";
+ # "Shift-Control-V" = "eval:paste_clipboard";
+ # "Shift-Control-+" = "command:\033]710;${font 12}\007\033]711;${font 12}\007";
+ # "Shift-Control--" = "command:\033]710;${font 8}\007\033]711;${font 8}\007";
+ #};
iso14755 = true; # unicode chars
#transparent = true;
#shading = 10;
@@ -293,7 +291,7 @@ in {
rev = "32b42c8a12bf9588259b76f3df6807960e0d7386";
sha256 = "sha256-kM7WP03uE20yr0nCusB3ncHzgtEYxqNzoNoQGen9p+o=";
};
- meta.homepate = "https://github.com/axvr/photon.vim";
+ meta.homepage = "https://github.com/axvr/photon.vim";
})
(pkgs.vimUtils.buildVimPlugin {
pname = "skull-vim";
@@ -304,7 +302,7 @@ in {
rev = "abb9d7120c63aad6f9acc26d31c948a93f352e94";
sha256 = "sha256-tu5aDRjHZtXKoyQBbMEhzjGrRl4GZD121ybs7oNylvs=";
};
- meta.homepate = "https://github.com/kadekillary/skull-vim";
+ meta.homepage = "https://github.com/kadekillary/skull-vim";
})
];
extraConfig = builtins.readFile ./vimrc;
@@ -321,9 +319,9 @@ in {
bash = {
enable = true;
initExtra = ''
- DIR=~/.nix-profile/etc/profile.d
- [[ -f "$DIR/nix.sh" ]] && . "$DIR/nix.sh"
- [[ -f "$DIR/hm-session-vars.sh" ]] && . "$DIR/hm-session-vars.sh"
+ #DIR=~/.nix-profile/etc/profile.d
+ #[[ -f "$DIR/nix.sh" ]] && . "$DIR/nix.sh"
+ #[[ -f "$DIR/hm-session-vars.sh" ]] && . "$DIR/hm-session-vars.sh"
[[ -f "${homedir}/.bashrc.local" ]] && . "${homedir}/.bashrc.local"
source "${pkgs.forgit}/share/bash/forgit.plugin.zsh"
function fcd() {
@@ -354,7 +352,7 @@ in {
gawk 'match($0,/'$1'/, ary) {print ary['\$\{2:-'0'}']}';
}
- export PS1='$(printf "%3.*s" $r $r)ϟ '
+ export PS1='$(printf "%3.*s" $? $?)ϟ '
# kill a process with fzf
fkill() {