summaryrefslogtreecommitdiff
path: root/lib/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/common.nix')
-rw-r--r--lib/common.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/lib/common.nix b/lib/common.nix
index 24e53e0..99cdbd8 100644
--- a/lib/common.nix
+++ b/lib/common.nix
@@ -18,6 +18,7 @@ in
LEDGER_FILE = "${homedir}/.hledger.journal";
XTERM_LOCALE = locale;
LOCALE_ARCHIVE = "${pkgs.glibcLocales}/lib/locale/locale-archive";
+ PYTHONSTARTUP = "${homedir}/.pythonrc";
};
# From the command line:
@@ -33,6 +34,14 @@ in
source = ./hledger.journal;
target = ".hledger.journal";
};
+ pythonrc = {
+ source = ./pythonrc;
+ target = ".pythonrc";
+ };
+ pdbrc = {
+ source = ./pythonrc;
+ target = ".pdbrc";
+ };
};
};