summaryrefslogtreecommitdiff
path: root/lib/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/common.nix')
-rw-r--r--lib/common.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/common.nix b/lib/common.nix
index 0975cfd..64d0829 100644
--- a/lib/common.nix
+++ b/lib/common.nix
@@ -22,6 +22,7 @@ in
FD_OPTIONS = "--follow --exclude .git";
BAT_PAGER = "less -R";
+ FZF_DEFAULT_OPTS = "--bind='?:toggle-preview'";
FZF_DEFAULT_COMMAND = "git ls-files --cached --others --exclude-standard | fd --type f --type l $FD_OPTIONS";
FZF_CTRL_T_COMMAND = "fd $FD_OPTIONS";
FZF_ALT_C_COMMAND = "fd --type d $FD_OPTIONS";
@@ -291,7 +292,7 @@ in
tdate = "date +%Y.%m.%d..%H.%M";
ttime = "date +%H.%M";
typeless = "history | tail -n 20000 | sed 's/.* //' | sort | uniq -c | sort -g | tail -n 100";
- v = "vim $(fzf)";
+ v = "vim $(fzf --preview='bat --color=always {}' --preview-window right:70%)";
"v." = "vim .";
};
};