summaryrefslogtreecommitdiff
path: root/lib/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/common.nix')
-rw-r--r--lib/common.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/lib/common.nix b/lib/common.nix
index 7059cba..4b189a7 100644
--- a/lib/common.nix
+++ b/lib/common.nix
@@ -6,6 +6,7 @@ let
homedir = builtins.getEnv "HOME";
in
{
+ nixpkgs.overlays = [ (import ../overlay.nix) ];
home = {
sessionVariables = {
GPGID = gpgid;
@@ -25,6 +26,12 @@ in
FZF_DEFAULT_COMMAND = "git ls-files --cached --others --exclude-standard | fd --type f --type l $FD_OPTIONS";
FZF_CTRL_T_COMMAND = "fd $FD_OPTIONS";
FZF_ALT_C_COMMAND = "fd --type d $FD_OPTIONS";
+ FORGIT_FZF_DEFAULT_OPTS = ''
+ --exact
+ --border
+ --cycle
+ --reverse
+ '';
};
# From the command line:
@@ -287,6 +294,9 @@ in
[[ -f "$DIR/nix.sh" ]] && . "$DIR/nix.sh"
[[ -f "$DIR/hm-session-vars.sh" ]] && . "$DIR/hm-session-vars.sh"
[[ -f "${homedir}/.bashrc.local" ]] && . "${homedir}/.bashrc.local"
+
+ source "${pkgs.forgit}/share/bash/forgit.plugin.zsh"
+
function cd() {
builtin cd "$@" && ls
}