summaryrefslogtreecommitdiff
path: root/lib/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/common.nix')
-rw-r--r--lib/common.nix11
1 files changed, 5 insertions, 6 deletions
diff --git a/lib/common.nix b/lib/common.nix
index 429d6b7..f7a7d35 100644
--- a/lib/common.nix
+++ b/lib/common.nix
@@ -135,11 +135,12 @@ in
enable = true;
};
- vim = {
+ neovim = {
enable = true;
- plugins = with pkgs.vimPlugins; [
- editorconfig-vim
- ];
+ vimAlias = true;
+ viAlias = true;
+ vimdiffAlias = true;
+ plugins = [ pkgs.vimPlugins.editorconfig-vim ];
extraConfig = builtins.readFile ./vimrc;
};
@@ -198,9 +199,7 @@ in
tdate = "date +%Y.%m.%d..%H.%M";
ttime = "date +%H.%M";
typeless = "history | tail -n 20000 | sed 's/.* //' | sort | uniq -c | sort -g | tail -n 100";
- v = "vim";
"v." = "vim .";
- vimdiff = "vim -d";
vk = "vim $(sk -m)";
vs = "vim $(sk -m)";
};