summaryrefslogtreecommitdiff
path: root/lib/email.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/email.nix')
-rw-r--r--lib/email.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/lib/email.nix b/lib/email.nix
index e874dd6..7f477e3 100644
--- a/lib/email.nix
+++ b/lib/email.nix
@@ -1,4 +1,4 @@
-{ pkgs, ... }:
+{ pkgs, lib, ... }:
let
gpgid = "D09299626FA78AF8";
@@ -48,9 +48,13 @@ in
programs = {
notmuch = {
enable = true;
- new.tags = [ "new" ];
+ new.tags = [ "unread" "inbox" ];
hooks = {
- postNew = "${pkgs.afew}/bin/afew -tn && ${pkgs.afew}/bin/afew -t tag:inbox";
+ postNew = lib.strings.concatStringsSep " && " [
+ "${pkgs.afew}/bin/afew --tag --new"
+ "${pkgs.afew}/bin/afew --tag tag:inbox"
+ "${pkgs.afew}/bin/afew --move-mail"
+ ];
};
extraConfig = {
search = {