summaryrefslogtreecommitdiff
path: root/lib/email.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/email.nix')
-rw-r--r--lib/email.nix13
1 files changed, 7 insertions, 6 deletions
diff --git a/lib/email.nix b/lib/email.nix
index 7f477e3..05cfd7e 100644
--- a/lib/email.nix
+++ b/lib/email.nix
@@ -48,13 +48,14 @@ in
programs = {
notmuch = {
enable = true;
- new.tags = [ "unread" "inbox" ];
+ new.tags = [ "new" ];
+ maildir.synchronizeFlags = true;
hooks = {
- postNew = lib.strings.concatStringsSep " && " [
- "${pkgs.afew}/bin/afew --tag --new"
- "${pkgs.afew}/bin/afew --tag tag:inbox"
- "${pkgs.afew}/bin/afew --move-mail"
- ];
+ postNew = ''
+ ${pkgs.afew}/bin/afew --tag --new
+ ${pkgs.afew}/bin/afew --tag tag:inbox
+ ${pkgs.afew}/bin/afew --move-mail
+ '';
};
extraConfig = {
search = {