summaryrefslogtreecommitdiff
path: root/lib/linux.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/linux.nix')
-rw-r--r--lib/linux.nix164
1 files changed, 11 insertions, 153 deletions
diff --git a/lib/linux.nix b/lib/linux.nix
index e80b71f..ba0fbdf 100644
--- a/lib/linux.nix
+++ b/lib/linux.nix
@@ -2,24 +2,9 @@
let
inherit (import ./const.nix) fontSize homedir gpgid;
- base16-scheme = "atelier-sulphurpool";
- base16-scheme-filename = lib.strings.concatStrings (lib.strings.splitString "-" base16-scheme);
- theme = lib.removeSuffix "\n" (builtins.readFile "${homedir}/.local/share/xtheme");
- xresourcesFile = "${pkgs.base16}/xresources/base16-${base16-scheme-filename}.${theme}.256.xresources";
-
- # used in polybar and dunst
- colors = { # derived from spacemacs
- "dark" = {
- highlight = "#5d4d7a";
- background = "#292b2e";
- foreground = "#b2b2b2";
- };
- "light" = {
- highlight = "#67b11d";
- background = "#f6f1e1";
- foreground = "#655370";
- };
- };
+ inherit (import ./theme.nix { inherit pkgs lib; })
+ theme colors base16-scheme base16-scheme-filename
+ xresourcesFile;
xmonadPackages = self: [
self.xmonad-contrib
#self.taffybar # fails to build
@@ -30,6 +15,10 @@ in
{
imports = [
./common.nix
+
+ # nix-channel --add https://github.com/catppuccin/nix/archive/main.tar.gz catppuccin
+ #<catppuccin/modules/home-manager>
+
];
home = {
pointerCursor = {
@@ -100,6 +89,10 @@ in
zathura
];
};
+
+ #catppuccin.flavor = "latte";
+ #catppuccin.enable = true;
+
fonts.fontconfig.enable = true;
gtk.enable = false; # this fails because of some missing service file
@@ -140,141 +133,6 @@ in
postExec = "${pkgs.notmuch}/bin/notmuch new";
};
- polybar = {
- # https://github.com/0x746866/dots/blob/master/polybar/config
- enable = true;
- config = {
- "bar/top" = {
- background = colors."${theme}".background;
- font-0 = "FiraSans:size=${toString fontSize}";
- font-1 = "Font Awesome 5:pixelsize=11;1";
- font-2 = "MaterialIcons:size=10:antialias=false;2";
- foreground = colors."${theme}".foreground;
- height = "30";
- module-margin = 1;
- modules-center = "date";
- modules-left = ["ewmh" "volume-bar"];
- modules-right = [ "battery" "cpu" "mem" "temp" ];
- monitor = "\${env:MONITOR:HDMI-2}";
- monitor-fallback = "\${env:MONITOR:eDP-1}";
- radius = 0;
- separator = "|";
- tray-background = colors."${theme}".background;
- tray-detached = false;
- tray-maxsize = 16;
- tray-offset-x = 0;
- tray-offset-y = 0;
- tray-padding = 0;
- tray-position = "right";
- tray-scale = 1;
- width = "100%";
- };
- "module/ewmh" = {
- type = "internal/xworkspaces";
- label-active-foreground = "#fff";
- };
- "module/date" = {
- type = "internal/date";
- internal = 5;
- date = "%Y.%m.%d";
- time = "%H.%M";
- label = "%date%..%time%";
- };
- "module/battery" = {
- type = "internal/battery";
- battery = "BAT0";
- adapter = "AC";
- full-at = 99;
- };
- "module/volume-bar" = {
- type = "internal/alsa";
- master-soundcard = "hw:1";
- bar-volume-font = 2;
- bar-volume-width = 9;
- format-volume = "<label-volume><bar-volume>";
- label-volume = " .) ";
- label-muted = " .) mute";
- label-volume-foreground = colors.${theme}.foreground;
- format-muted-foreground = colors.${theme}.foreground;
- bar-volume-foreground-0 = colors.${theme}.foreground;
- bar-volume-foreground-1 = colors.${theme}.foreground;
- bar-volume-foreground-2 = colors.${theme}.foreground;
- bar-volume-foreground-3 = colors.${theme}.foreground;
- bar-volume-foreground-4 = colors.${theme}.foreground;
- bar-volume-foreground-5 = colors.${theme}.foreground;
- bar-volume-foreground-6 = colors.${theme}.foreground;
- bar-volume-gradient = true;
- bar-volume-indicator = "•";
- bar-volume-fill = "•";
- bar-volume-empty = "·";
- bar-volume-empty-foreground = colors.${theme}.foreground;
- };
- "module/ethernet" = {
- type = "internal/network";
- interface = "enp1s0";
- label-connected = "eth up: %upspeed:9% down: %downspeed%";
- label-disconnected = "no eth";
- };
- "module/wifi" = {
- type = "internal/network";
- interface = "wlan1";
- label-connected = "wifi up: %upspeed% down: %downspeed%";
- label-disconnected = "no wifi";
- };
- "module/cpu" = {
- type = "internal/cpu";
- interval = 3;
- format-padding = 1;
- format = "<label> <ramp-coreload>";
- label = " %percentage:2%%";
- ramp-coreload-0 = "▂";
- ramp-coreload-1 = "▃";
- ramp-coreload-2 = "▄";
- ramp-coreload-3 = "▅";
- ramp-coreload-4 = "▆";
- ramp-coreload-5 = "▇";
- ramp-coreload-0-foreground = colors.${theme}.foreground;
- ramp-coreload-1-foreground = colors.${theme}.foreground;
- ramp-coreload-2-foreground = colors.${theme}.foreground;
- ramp-coreload-3-foreground = colors.${theme}.foreground;
- ramp-coreload-4-foreground = colors.${theme}.foreground;
- ramp-coreload-5-foreground = colors.${theme}.highlight;
- };
- "module/temp" = {
- type = "internal/temperature";
- interval = 3;
- thermal-zone = 0;
- warn-temperature = 70;
- format = "<ramp> <label>";
- format-padding = 1;
- label = "%temperature-c%";
- ramp-0 = "_";
- ramp-1 = ".";
- ramp-2 = ":";
- ramp-3 = "|";
- ramp-4 = "!!";
- ramp-0-foreground = colors.${theme}.foreground;
- ramp-1-foreground = colors.${theme}.foreground;
- ramp-2-foreground = colors.${theme}.foreground;
- ramp-3-foreground = colors.${theme}.foreground;
- ramp-4-foreground = colors.${theme}.highlight;
- format-warn = "<label-warn>";
- label-warn = " %temperature-c%";
- label-warn-padding = 1;
- label-warn-foreground = colors.${theme}.highlight;
- };
- "module/mem" = {
- type = "internal/memory";
- interval = 3;
- format = "<label>";
- label-padding = 1;
- label = " |[]| %percentage_used%%";
- };
- };
- script = ''
- polybar top &
- '';
- };
dunst = {
enable = true;