summaryrefslogtreecommitdiff
path: root/lib/linux.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/linux.nix')
-rw-r--r--lib/linux.nix23
1 files changed, 14 insertions, 9 deletions
diff --git a/lib/linux.nix b/lib/linux.nix
index 15ea28a..a4af6c2 100644
--- a/lib/linux.nix
+++ b/lib/linux.nix
@@ -1,11 +1,10 @@
{ pkgs, lib, ... }:
let
- homedir = builtins.getEnv "HOME";
+ inherit (import ./const.nix) fontSize homedir gpgid;
getHostname = pkgs.runCommand "hostname" {}
"${pkgs.hostname}/bin/hostname > $out";
hostname = lib.strings.removeSuffix "\n" (builtins.readFile "${getHostname}");
- gpgid = "66A6AD150399D970DCA4C4E6C8218B7D0BFDECCD";
base16-scheme = "atelier-sulphurpool";
base16-scheme-filename = lib.strings.concatStrings (lib.strings.splitString "-" base16-scheme);
theme = lib.removeSuffix "\n" (builtins.readFile "${homedir}/.local/share/xtheme");
@@ -96,23 +95,29 @@ in
xdotool
xlayoutdisplay
xorg.xmodmap
+ xsel
xterm
yank
youtube-dl
yubioath-desktop
zathura
-
- # languages i regularly use
- (haskellPackages.ghcWithPackages (a: with a; [hledger rainbow])) # for hledger scripting
];
};
fonts.fontconfig.enable = true;
+ gtk.enable = false; # this fails because of some missing service file
+ gtk.font.name = "Fira Sans";
+ gtk.font.size = fontSize;
+ gtk.font.package = pkgs.fira;
+ gtk.theme.name = "Breeze";
+ gtk.iconTheme.name = "hicolor";
+ gtk.cursorTheme.name = "breeze_cursors";
+
xresources = {
properties = {
- "XTerm*font" = "-*-FiraMono-medium-r-normal--10-*-*-*-*-*-iso10646-1";
+ "XTerm*font" = "-*-FiraMono-medium-r-normal--${toString fontSize}-*-*-*-*-*-iso10646-1";
"XTerm*faceName" = "FireMono";
- "XTerm*faceSize" = "10";
+ "XTerm*faceSize" = toString fontSize;
"XTerm*termName" = "xterm-256color";
"XTerm*metaSendsEscape" = true;
"XTerm*utf8" = true;
@@ -145,7 +150,7 @@ in
config = {
"bar/top" = {
background = colors."${theme}".background;
- font-0 = "FiraSans:size=16";
+ font-0 = "FiraSans:size=${toString fontSize}";
font-1 = "Font Awesome 5:pixelsize=11;1";
font-2 = "MaterialIcons:size=10:antialias=false;2";
foreground = colors."${theme}".foreground;
@@ -303,7 +308,7 @@ in
};
redshift = {
- enable = true;
+ enable = false;
latitude = "40.80";
longitude = "-81.52";
temperature = {