summaryrefslogtreecommitdiff
path: root/lib/linux.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/linux.nix')
-rw-r--r--lib/linux.nix5
1 files changed, 0 insertions, 5 deletions
diff --git a/lib/linux.nix b/lib/linux.nix
index 91c0c33..ad85407 100644
--- a/lib/linux.nix
+++ b/lib/linux.nix
@@ -2,9 +2,6 @@
let
inherit (import ./const.nix) fontSize homedir gpgid;
- getHostname = pkgs.runCommand "hostname" {}
- "${pkgs.hostname}/bin/hostname > $out";
- hostname = lib.strings.removeSuffix "\n" (builtins.readFile "${getHostname}");
base16-scheme = "atelier-sulphurpool";
base16-scheme-filename = lib.strings.concatStrings (lib.strings.splitString "-" base16-scheme);
theme = lib.removeSuffix "\n" (builtins.readFile "${homedir}/.local/share/xtheme");
@@ -33,7 +30,6 @@ in
{
imports = [
./common.nix
- ./email.nix
];
home = {
pointerCursor = {
@@ -140,7 +136,6 @@ in
keybase.enable = false;
mbsync = {
- enable = if hostname == "lithium" then true else false;
frequency = "*:0/5";
postExec = "${pkgs.notmuch}/bin/notmuch new";
};