summaryrefslogtreecommitdiff
path: root/lib/ssh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/ssh.nix')
-rw-r--r--lib/ssh.nix31
1 files changed, 13 insertions, 18 deletions
diff --git a/lib/ssh.nix b/lib/ssh.nix
index 452f810..013e727 100644
--- a/lib/ssh.nix
+++ b/lib/ssh.nix
@@ -12,13 +12,6 @@ in {
# RemoteForward %d/.gnupg/S.gpg-agent ''${HOME}/.gnupg/S.gpg-agent.extra
'';
matchBlocks = {
- "github.com" = {
- hostname = "github.com";
- user = "git";
- identityFile = [ "${homedir}/.ssh/id_rsa" ];
- identitiesOnly = true;
- };
-
# groq
"bsima" = {
hostname = "bsima"; # must be on vpn
@@ -45,12 +38,14 @@ in {
identityFile = [ "${homedir}/.ssh/id_rsa" ];
identitiesOnly = true;
};
- "simatime.com" = {
- hostname = "simatime.com";
- user = "git";
- identityFile = [ "${homedir}/.ssh/id_rsa" ];
- identitiesOnly = true;
- };
+ #"simatime.com" = {
+ # hostname = "simatime.com";
+ # user = "git";
+ # identitiesOnly = true;
+ # extraOptions = {
+ # # PKCS11Provider = "/run/current-system/sw/lib/opensc-pkcs11.so";
+ # };
+ #};
"gerrit.simatime.com" = {
hostname = "gerrit.simatime.com";
user = "bsima";
@@ -63,11 +58,11 @@ in {
identityFile = [ "${homedir}/.ssh/id_rsa" ];
identitiesOnly = true;
};
- "dev.simatime.com" = {
- user = "ben";
- identityFile = [ "${homedir}/.ssh/id_rsa" ];
- identitiesOnly = true;
- };
+ #"dev.simatime.com" = {
+ # user = "ben";
+ # identityFile = [ "${homedir}/.ssh/id_rsa" ];
+ # identitiesOnly = true;
+ #};
"git.platonic.systems" = {
hostname = "git.platonic.systems";
user = "git";