summaryrefslogtreecommitdiff
path: root/linux.nix
diff options
context:
space:
mode:
Diffstat (limited to 'linux.nix')
-rw-r--r--linux.nix14
1 files changed, 13 insertions, 1 deletions
diff --git a/linux.nix b/linux.nix
index 7f2ec02..d86135e 100644
--- a/linux.nix
+++ b/linux.nix
@@ -356,7 +356,7 @@ in
gpg-agent = {
enable = true;
- enableScDaemon = true;
+ enableScDaemon = true; # smart card support
defaultCacheTtl = 1800; # 30 minutes
maxCacheTtl = 7200; # 2 hours
enableSshSupport = false;
@@ -412,4 +412,16 @@ in
enable = true;
};
};
+
+ systemd.user = {
+ services = {
+ "gpg-refresh".Service.ExecStart = "${pkgs.gnupg}/bin/gpg --refresh";
+ };
+ timers = {
+ "gpg-refresh" = {
+ Install.WantedBy = ["timers.target"];
+ Timer.OnCalendar = "daily";
+ };
+ };
+ };
}