summaryrefslogtreecommitdiff
path: root/linux.nix
diff options
context:
space:
mode:
Diffstat (limited to 'linux.nix')
-rw-r--r--linux.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/linux.nix b/linux.nix
index 7e6a775..7a84646 100644
--- a/linux.nix
+++ b/linux.nix
@@ -2,7 +2,7 @@
let
homedir = builtins.getEnv "HOME";
- hostname = builtins.getEnv "HOSTNAME";
+ hostname = lib.strings.removeSuffix "\n" (builtins.readFile /etc/hostname);
gpgid = "D09299626FA78AF8";
cmdtree = pkgs.stdenv.mkDerivation {
name = "cmdtree";
@@ -177,8 +177,8 @@ in
keybase.enable = true;
mbsync = {
- enable = false; #if hostname == "lithium" then true else false;
- frequency = "*:0/15";
+ enable = if hostname == "lithium" then true else false;
+ frequency = "*:0/5";
postExec = "${pkgs.notmuch}/bin/notmuch new";
};
@@ -366,6 +366,7 @@ in
enableSshSupport = false;
enableExtraSocket = true;
verbose = true;
+ pinentryFlavor = "curses";
extraConfig = ''
allow-emacs-pinentry
# StreamLocalBindUnlink yes