summaryrefslogtreecommitdiff
path: root/profiles/beryllium.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/beryllium.nix')
-rw-r--r--profiles/beryllium.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/profiles/beryllium.nix b/profiles/beryllium.nix
new file mode 100644
index 0000000..b4f794b
--- /dev/null
+++ b/profiles/beryllium.nix
@@ -0,0 +1,24 @@
+# beryllium server
+{ pkgs, lib, ... }:
+
+{
+ imports = [
+ ../lib/linux.nix
+ ../lib/ssh.nix
+ ../lib/packages.nix
+ ../lib/emacs.nix
+ ../lib/email.nix
+ ];
+
+ home = {
+ packages = with pkgs; [
+ zulip
+ ];
+ };
+
+ services.polybar.config."bar/top".monitor = lib.mkForce "HDMI-0";
+
+ services.random-background.enable = lib.mkForce true;
+
+ programs.git.signing.signByDefault = lib.mkForce false;
+}