summaryrefslogtreecommitdiff
path: root/profiles/darwin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/darwin.nix')
-rw-r--r--profiles/darwin.nix28
1 files changed, 14 insertions, 14 deletions
diff --git a/profiles/darwin.nix b/profiles/darwin.nix
index c221e9e..9640d22 100644
--- a/profiles/darwin.nix
+++ b/profiles/darwin.nix
@@ -2,29 +2,29 @@
let
homedir = builtins.getEnv "HOME";
- haskellOverlay = self: super: {
- haskellPackages = super.haskellPackages.override (old: {
- overrides = self: super: {
- hledger = self.callPackage ./pkgs/hledger-1.19.1.nix {};
- hledger-lib = self.callPackage ./pkgs/hledger-lib-1.19.1.nix {};
- };
- });
- };
+ #haskellOverlay = self: super: {
+ # haskellPackages = super.haskellPackages.override (old: {
+ # overrides = self: super: {
+ # hledger = self.callPackage ./pkgs/hledger-1.19.1.nix {};
+ # hledger-lib = self.callPackage ./pkgs/hledger-lib-1.19.1.nix {};
+ # };
+ # });
+ #};
in
{
nixpkgs.overlays = [
- haskellOverlay
+ #haskellOverlay
];
imports = [
- ./lib/common.nix
- ./lib/email.nix
+ ../lib/common.nix
+ #../lib/email.nix
+ ../lib/ssh.nix
];
home = {
- sessionVariables.PATH = "/usr/local/opt/mysql@5.7/bin:${homedir}/bin:${homedir}/.cabal/bin:${homedir}/.local/bin:$PATH";
packages = with pkgs; [
- muchsync
- (haskellPackages.ghcWithPackages (ps: with ps; [hledger]))
+ #muchsync
+ #(haskellPackages.ghcWithPackages (ps: with ps; [hledger]))
coreutils
];
};