summaryrefslogtreecommitdiff
path: root/profiles/groq.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/groq.nix')
-rw-r--r--profiles/groq.nix17
1 files changed, 15 insertions, 2 deletions
diff --git a/profiles/groq.nix b/profiles/groq.nix
index a12a5a2..757b47b 100644
--- a/profiles/groq.nix
+++ b/profiles/groq.nix
@@ -1,12 +1,25 @@
{ pkgs, lib, ... }:
-{
+let
+ homedir = builtins.getEnv "HOME";
+in {
imports = [
../lib/common.nix
../lib/packages.nix
- ../lib/ssh.nix
];
programs.git.userEmail = lib.mkOverride 10 "bsima@groq.com";
services.emacs.enable = true;
+
+ # i use a separate passphrase-protected key for getting my personal git repos
+ # onto my groq machine
+ programs.ssh = {
+ enable = true;
+ matchBlocks."simatime.com" = {
+ hostname = "simatime.com";
+ user = "git";
+ identityFile = [ "${homedir}/.ssh/git@simatime.com" ];
+ identitiesOnly = true;
+ };
+ };
}