summaryrefslogtreecommitdiff
path: root/profiles/workshop.nix
diff options
context:
space:
mode:
Diffstat (limited to 'profiles/workshop.nix')
-rw-r--r--profiles/workshop.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/profiles/workshop.nix b/profiles/workshop.nix
index 783d75d..311aeab 100644
--- a/profiles/workshop.nix
+++ b/profiles/workshop.nix
@@ -8,6 +8,7 @@
../lib/packages.nix
../lib/emacs.nix
];
+
home = {
sessionVariables = {
GPGID = "C184FB3920E3510D";
@@ -16,9 +17,13 @@
weechat
];
};
+
services.polybar.config."bar/top".monitor = lib.mkForce "HDMI-1";
+
services.random-background.enable = lib.mkForce true;
+
programs.git.signing.signByDefault = true;
+
systemd.user.services = {
"shop-music".Service = {
RestartSec = "3s";
@@ -26,4 +31,25 @@
ExecStart = "${pkgs.mplayer}/bin/mplayer http://localhost:8097";
};
};
+
+ services.mpd = {
+ enable = true;
+ musicDirectory = "/mnt/campbell/ben/music";
+ network = {
+ listenAddress = "0.0.0.0";
+ port = 6600;
+ };
+ extraConfig = ''
+ audio_output {
+ type "httpd"
+ name "HTTP Stream"
+ encoder "vorbis"
+ port "8097"
+ quality "7.0"
+ format "44100:16:2"
+ }
+ '';
+ };
+
+
}