summaryrefslogtreecommitdiff
path: root/vim.nix
diff options
context:
space:
mode:
Diffstat (limited to 'vim.nix')
-rw-r--r--vim.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/vim.nix b/vim.nix
new file mode 100644
index 0000000..57f79ba
--- /dev/null
+++ b/vim.nix
@@ -0,0 +1,16 @@
+{ ... }:
+
+{
+ programs.vim = {
+ enable = true;
+ plugins = [
+ "ctrlp"
+ "fugitive"
+ "editorconfig-vim"
+ "surround"
+ "vim-colorschemes"
+ "vim-ripgrep"
+ ];
+ extraConfig = builtins.readFile ../vimrc;
+ };
+}