summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..b5c4f45
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,19 @@
+{ pkgs ? import <nixpkgs> {} }:
+
+pkgs.mkShell {
+
+ packages = with pkgs; [
+ lolcat
+ (lispPackages_new.sbclWithPackages (p: with p; [
+ asdf
+ swank
+ quickproject
+ alexandria
+ ]))
+ ];
+
+ shellHook = ''
+ echo cl-gemini | figlet | lolcat
+ '';
+
+}