summaryrefslogtreecommitdiff
path: root/anonco/shell.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2018-07-11 12:57:18 -0700
committerBen Sima <ben@bsima.me>2018-07-11 12:57:18 -0700
commitb26eb3413979ddf8a676b604401f9853d5a342bc (patch)
tree4f4e7373f4b50353cf5c4b08fb2fde03d544f305 /anonco/shell.nix
parent781400254cf01bc564ddf96b68a4ba690424a264 (diff)
Rename to anonco
Diffstat (limited to 'anonco/shell.nix')
-rw-r--r--anonco/shell.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/anonco/shell.nix b/anonco/shell.nix
new file mode 100644
index 0000000..56160f4
--- /dev/null
+++ b/anonco/shell.nix
@@ -0,0 +1,28 @@
+{ nixpkgs ? import <nixpkgs> {}, compiler ? "default", doBenchmark ? false }:
+
+let
+
+ inherit (nixpkgs) pkgs;
+
+ f = { mkDerivation, base, random, split, stdenv }:
+ mkDerivation {
+ pname = "anonco";
+ version = "0.1.0.0";
+ src = ./.;
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [ base random split ];
+ license = stdenv.lib.licenses.bsd3;
+ };
+
+ haskellPackages = if compiler == "default"
+ then pkgs.haskellPackages
+ else pkgs.haskell.packages.${compiler};
+
+ variant = if doBenchmark then pkgs.haskell.lib.doBenchmark else pkgs.lib.id;
+
+ drv = variant (haskellPackages.callPackage f {});
+
+in
+
+ if pkgs.lib.inNixShell then drv.env else drv