summaryrefslogtreecommitdiff
path: root/simspace/default.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2018-06-29 19:36:08 -0700
committerBen Sima <ben@bsima.me>2018-06-29 19:36:08 -0700
commite81da383d908d4b7597cb73dc489f5162fcf19bf (patch)
treec4ac7ea73b180a533937cb26787ce4f095a690b7 /simspace/default.nix
parent66e6b47737a9e6411f430a5cd169315f04dcd078 (diff)
Add simspace
Theres a bug, need Wolfram's book to get into the math of it, I can't find a good explanation of the actual math anywhere (the wikipedia page is pretty bad)
Diffstat (limited to 'simspace/default.nix')
-rw-r--r--simspace/default.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/simspace/default.nix b/simspace/default.nix
new file mode 100644
index 0000000..84e0349
--- /dev/null
+++ b/simspace/default.nix
@@ -0,0 +1,10 @@
+{ mkDerivation, base, random, split, stdenv }:
+mkDerivation {
+ pname = "simspace";
+ version = "0.1.0.0";
+ src = ./.;
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [ base random split ];
+ license = stdenv.lib.licenses.bsd3;
+}