summaryrefslogtreecommitdiff
path: root/simspace/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'simspace/shell.nix')
-rw-r--r--simspace/shell.nix28
1 files changed, 0 insertions, 28 deletions
diff --git a/simspace/shell.nix b/simspace/shell.nix
deleted file mode 100644
index 757c212..0000000
--- a/simspace/shell.nix
+++ /dev/null
@@ -1,28 +0,0 @@
-{ nixpkgs ? import <nixpkgs> {}, compiler ? "default", doBenchmark ? false }:
-
-let
-
- inherit (nixpkgs) pkgs;
-
- f = { mkDerivation, base, random, split, stdenv }:
- mkDerivation {
- pname = "simspace";
- version = "0.1.0.0";
- src = ./.;
- isLibrary = false;
- isExecutable = true;
- executableHaskellDepends = [ base random split ];
- license = stdenv.lib.licenses.bsd3;
- };
-
- haskellPackages = if compiler == "default"
- then pkgs.haskellPackages
- else pkgs.haskell.packages.${compiler};
-
- variant = if doBenchmark then pkgs.haskell.lib.doBenchmark else pkgs.lib.id;
-
- drv = variant (haskellPackages.callPackage f {});
-
-in
-
- if pkgs.lib.inNixShell then drv.env else drv