summaryrefslogtreecommitdiff
path: root/Biz.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2024-12-20 13:21:43 -0500
committerBen Sima <ben@bsima.me>2024-12-21 10:08:11 -0500
commit32d31ae8d1ef5d5aeb03a7fe7e6a294e14905505 (patch)
tree4a248394a7c49682f9ef7538e3033fbea5117690 /Biz.nix
parent87ead51331bc57326882055e1635a84c2d409af7 (diff)
Build and deploy storybook
I put the storybook into a new Biz.nix deploy target. The idea here is that any Biz/* targets should be hosted by this one VM for simplicity. Over time I can grow this as need be, but this should work to host a few services.
Diffstat (limited to 'Biz.nix')
-rw-r--r--Biz.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/Biz.nix b/Biz.nix
new file mode 100644
index 0000000..c87f91a
--- /dev/null
+++ b/Biz.nix
@@ -0,0 +1,25 @@
+# nunya
+{ bild, ... }:
+
+# This is the biz hosting service. Currently it defines a base OS similar to
+# Omni/Cloud.nix et al and starts each Biz/* thing as a systemd service. A
+# better solution might be to define each Biz/* thing as a container, and then
+# wire them together as necessary here, but I don't know how that works so I'll
+# just stick to this method for now.
+
+bild.os {
+ imports = [
+ ./Omni/Cloud/Hardware.nix
+ ./Omni/Os/Base.nix
+ ./Omni/Packages.nix
+ ./Omni/Users.nix
+ ./Biz/Storybook.nix
+ ];
+ networking.hostName = "biz";
+ networking.domain = "storybook.bensima.com";
+ time.timeZone = "America/New_York";
+ services.storybook = {
+ enable = true;
+ package = bild.run ./Biz/Storybook.py;
+ };
+}