summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2022-07-19 14:22:53 -0400
committerBen Sima <ben@bsima.me>2022-07-19 14:25:23 -0400
commit08e10dec6b00cedf7aa6395d195a32860e35a690 (patch)
treec1e0c93de05f5fc5c1f4dcb0dce7bcbdaba815c1 /Biz/Bild.nix
parentde3edfca6fd628494be5e04ff3dbe21a54441163 (diff)
Provision lisp repls with nix
asdf seems to always be necessary for any other packages to work, so I just include that in the call to nix-shell, and swank is included because it's just useful to start a repl server.
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index e675b68..700ea36 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -23,6 +23,8 @@ rec {
ghcWith = nixpkgs.haskell.packages.${constants.ghcCompiler}.ghcWithHoogle;
#mkGhcjsPackageSet = nixpkgs.haskell.packages.${ghcjsCompiler}.ghcWithPackages;
+ sbclWith = nixpkgs.lispPackages_new.sbclWithPackages;
+
ghcPackageSetFull = private.ghcWith private.haskellDeps;
ghcPackageSetBild = private.ghcWith (hpkgs: with hpkgs; [
aeson async base bytestring conduit conduit-extra containers directory
@@ -154,8 +156,6 @@ rec {
#python38Packages.black
#python38Packages.pylint
rustc
- sbcl
- lispPackages.swank
shellcheck
wemux
] ++ lib.optional nixpkgs.stdenv.isLinux [