summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2021-08-30 20:19:13 -0400
committerBen Sima <ben@bsima.me>2021-11-26 13:47:38 -0500
commit09882de5f3cbfd62d59b9ec94723a90d67555b7d (patch)
tree69f1c1fb85b7706e83be35c93fbd9d63d1b07dec /Biz/Bild.nix
parent1a5ea40711e35f8b108d10a0667423926d63fd34 (diff)
Update to ghc 8.10.4
This also makes some changes to the build tooling to clean up the environment a bit, and get us closer to 'bild -s'.
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix37
1 files changed, 8 insertions, 29 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index 3cd5026..6a0ce0c 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -1,10 +1,8 @@
{ nixpkgs ? import ./Bild/Nixpkgs.nix }:
+with import ./Bild/Constants.nix;
let
- ghcCompiler = "ghc884";
- ghcjsCompiler = "ghcjs86";
-
# provided by .envrc
root = builtins.getEnv "BIZ_ROOT";
@@ -23,6 +21,7 @@ let
mkGhcPackageSet = nixpkgs.haskell.packages.${ghcCompiler}.ghcWithHoogle;
#mkGhcjsPackageSet = nixpkgs.haskell.packages.${ghcjsCompiler}.ghcWithPackages;
+ ghcPackageSetFull = mkGhcPackageSet haskellDeps;
in rec {
inherit (nixpkgs) lib stdenv pkgs sources;
@@ -32,8 +31,7 @@ in rec {
name = "bild";
src = ../.;
nativeBuildInputs = [ ghcPackageSetFull ];
- buildInputs = [ ghcPackageSetFull nixpkgs.makeWrapper ];
- propagatedBuildInputs = [ ghcPackageSetFull ];
+ buildInputs = [ nixpkgs.makeWrapper ];
strictDeps = true;
buildPhase = ''
mkdir -p $out/bin
@@ -72,7 +70,6 @@ in rec {
(lib.trivial.importJSON
(runBildAnalyze main + "/analysis.json"));
- ghcPackageSetFull = mkGhcPackageSet haskellDeps;
ghc = main:
let
@@ -127,27 +124,10 @@ in rec {
env = pkgs.mkShell {
name = "bizdev";
buildInputs = with nixpkgs.pkgs; [
- # haskell deps
- (mkGhcPackageSet haskellDeps)
- # ghcjs doesn't need everything, and many things fail to build
- #(mkGhcjsPackageSet (hp: with hp; [
- # aeson
- # clay
- # containers
- # miso
- # protolude
- # servant
- # split
- # text
- # ghcjs-base
- #]))
-
- # python deps
- (python38.withPackages (p:
- [ p.black p.pylint ]))
-
- # tools
+ ghcPackageSetFull # need this until 'bild -s' works
+ # this should just be dev tools
haskell.packages.${ghcCompiler}.apply-refact
+ bild
cmark
figlet
haskell.packages.${ghcCompiler}.fast-tags
@@ -156,8 +136,8 @@ in rec {
niv.niv
nixops
ormolu
- python37Packages.black
- python37Packages.pylint
+ python38Packages.black
+ python38Packages.pylint
shellcheck
wemux
gmnisrv
@@ -167,7 +147,6 @@ in rec {
guile
#inspekt3d
#libfive
-
ccze
];
shellHook = ". ${./Bild/ShellHook.sh}";