summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2021-12-16 07:55:19 -0500
committerBen Sima <ben@bsima.me>2021-12-21 11:01:54 -0500
commit3fad7346721514af8bbe457abd61aab97916d2e3 (patch)
tree1ed071f885fa34784884cf6451c7a11381915cdc /Biz/Bild.nix
parentd62b0be79cb80d020a2354b3e09d451848e492a1 (diff)
Fix bild --repl to use the proper hasakell package set
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix12
1 files changed, 8 insertions, 4 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index 6279d2f..eb4821d 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -16,7 +16,7 @@ let
# 44 = lib.strings.stringLength "/nix/store/gia2r9mxhc900y1m97dlmr1g3rm3ich3-"
dropNixStore = s: nixpkgs.lib.strings.substring 44 (nixpkgs.lib.strings.stringLength s) s;
- haskellDeps = hpkgs: import ./Bild/Deps/Haskell.nix hpkgs;
+ haskellDeps = import ./Bild/Deps/Haskell.nix;
mkGhcPackageSet = nixpkgs.haskell.packages.${ghcCompiler}.ghcWithHoogle;
#mkGhcjsPackageSet = nixpkgs.haskell.packages.${ghcjsCompiler}.ghcWithPackages;
@@ -29,7 +29,9 @@ let
wai # can remove when removed from Biz.Log
]);
in rec {
- inherit (nixpkgs) lib stdenv pkgs sources;
+ inherit (nixpkgs) lib stdenv sources;
+
+ inherit mkGhcPackageSet;
# a standard nix build for `bild` - this should be the only hand-written
# builder we need
@@ -135,7 +137,7 @@ in rec {
# installPhase = "exit 0";
# } // { env = ghcjs; };
- env = pkgs.mkShell {
+ env = nixpkgs.pkgs.mkShell {
name = "bizdev";
buildInputs = with nixpkgs.pkgs; [
# this should just be dev tools
@@ -163,5 +165,7 @@ in rec {
os = cfg: (nixpkgs.nixos (args: cfg)).toplevel;
- image = pkgs.dockerTools.buildImage;
+ pkgs = { inherit (nixpkgs) git; };
+
+ image = nixpkgs.pkgs.dockerTools.buildImage;
}