summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2023-09-21 22:30:17 -0400
committerBen Sima <ben@bsima.me>2023-10-03 21:33:37 -0400
commit4226cbd8020253b010fb44d395db12efe68e1272 (patch)
tree4ee121a0cf26098b1cec1feed24c2cdd8e036562 /Biz/Bild.nix
parentdbdf4da2576f889544a33ce0bad4b8a5ff3eca87 (diff)
Rename BIZ_ROOT to CODEROOT
BIZ_ROOT was too specific. CODEROOT allows for other (non-biz) projects to live in the root of the repo. I didn't want to call it GIT_ROOT because maybe someday I won't want to use git. But I'll never not use code.
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index b12b87a..c7c3207 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -6,7 +6,7 @@ let
# put all of our stuff in the 'bild' namespace
in nixpkgs // { bild = rec {
# provided by .envrc
- root = builtins.getEnv "BIZ_ROOT";
+ root = builtins.getEnv "CODEROOT";
inherit (nixpkgs) sources;
@@ -97,7 +97,7 @@ in nixpkgs // { bild = rec {
USER = "nixbld";
HOSTNAME = "nix-sandbox";
# this is the default sandbox path where bild will be working:
- BIZ_ROOT = "/build/biz";
+ CODEROOT = "/build/biz";
# we need to remove the $src root because bild expects paths relative to the
# working directory:
TARGET = "." + lib.strings.removePrefix (toString src) (toString target);