summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2023-07-31 21:51:15 -0400
committerBen Sima <ben@bsima.me>2023-07-31 21:51:15 -0400
commit4cb9f2fbfbb124b38f19c72059620f25b71f92b7 (patch)
treea4101b59d46753692a0edb559c1d82f6a87837d7 /Biz/Bild.nix
parent1f2a9f1a331ebd64589da5e41692851ab47cf456 (diff)
Implement nix builds for Haskell
This is prototype quality. For some reason I think it breaks when doing `build **/*.hs`, which isn't good. But also it's working, and the code feels good. Next I'd like to get Python builds working, as hopefully that will force me to improve the existing code to support a second language.
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index 2a049b0..34d8174 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -30,13 +30,14 @@ rec {
ghcPackageSetBild = private.ghcWith (hpkgs: with hpkgs; [
aeson async base bytestring conduit conduit-extra containers directory
docopt filepath process protolude rainbow regex-applicative split tasty
- tasty-hunit tasty-quickcheck text
+ tasty-hunit tasty-quickcheck text neat-interpolation
wai # can remove when removed from Biz.Log
]);
+ ghcPackageSetMin = private.ghcWith (hpkgs: with hpkgs; []);
};
# generally-useful things from nixpkgs
- inherit (nixpkgs) lib stdenv sources runCommand;
+ inherit (nixpkgs) lib stdenv sources;
# expose some packages for inclusion in os/image builds
pkgs = with nixpkgs.pkgs; [ git ];
@@ -44,8 +45,8 @@ rec {
# remove this when I switch to all-nix builds
bildRuntimeDeps = with nixpkgs; [
pkg-config
+ private.ghcPackageSetMin
gnutls
- private.ghcPackageSetBild
rustc
# c deps
gcc gdb valgrind argp-standalone SDL