summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2023-08-10 21:10:24 -0400
committerBen Sima <ben@bsima.me>2023-08-16 14:29:43 -0400
commit4e67ef22a7508150798413081bf8a5bb4adab6e5 (patch)
treeaff33074e78a717b026b8df4748d0e5ec6e530eb /Biz/Bild.nix
parenta86cfcf95b19de667c88594f71324ee3370b9776 (diff)
Update nixpkgs to 23.05
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index ca9223f..0391d84 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -35,7 +35,7 @@ rec {
tasty-hunit tasty-quickcheck text neat-interpolation
wai # can remove when removed from Biz.Log
]);
- ghcPackageSetMin = private.ghcWith (hpkgs: with hpkgs; []);
+
};
# generally-useful things from nixpkgs
@@ -47,14 +47,17 @@ rec {
# remove this when I switch to all-nix builds
bildRuntimeDeps = with nixpkgs; [
pkg-config
- private.ghcPackageSetMin
- gnutls
+ # this is just to get access to ghc-pkg in bild
+ (private.ghcWith (hpkgs: with hpkgs; []))
+
+ /* disable until nixified builds are complete
rustc
# c deps
gcc gdb valgrind argp-standalone SDL
# lisp deps
guile
(private.sbclWith (p: with p; [asdf alexandria])) # just enough to build Example.lisp
+ */
];
# a standard nix build for `bild` - this should be the only hand-written