summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2023-10-07 09:25:58 -0400
committerBen Sima <ben@bsima.me>2023-10-10 13:16:49 -0400
commit6baad9c5fae4a7b8ea07376a0be52443eaa488fa (patch)
treebf8c953f7fa423bffbbcf35f114f68e67bc180c1 /Biz/Bild.nix
parent2c5ac71cdddae1ac48f2480069fba0f7f5f61b65 (diff)
Environment fixes on beryllium
Getting beryllium setup with the omnirepo showed that a few things needed fixed.
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index 9647983..409a0bc 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -130,15 +130,22 @@ in nixpkgs // { bild = rec {
name = "bizdev";
# this should just be dev tools
buildInputs = with nixpkgs.pkgs; [
+ bat
+ bc
bild
black
ctags
+ fd
figlet
+ fzf
git
gitlint
+ jq
lolcat
nixpkgs.haskell.packages.${constants.ghcCompiler}.fast-tags
ormolu
+ ripgrep
+ tree
wemux
];
shellHook = ''