summaryrefslogtreecommitdiff
path: root/Biz/Bild.nix
diff options
context:
space:
mode:
authorBen Sima <ben@bsima.me>2022-07-25 09:12:00 -0400
committerBen Sima <ben@bsima.me>2022-07-25 09:12:00 -0400
commit703f950a6316486bd626cb39e6cbe1484c5d2019 (patch)
tree01869e5ae2a034d8342dbd0a49b665ffbabe19f7 /Biz/Bild.nix
parentf91d101dffb51c8eb207914833d1a5241149ae7b (diff)
Remove GHCJS support completely
I don't care about ghcjs anymore, the most javascript I want to do is jQuery.
Diffstat (limited to 'Biz/Bild.nix')
-rw-r--r--Biz/Bild.nix26
1 files changed, 0 insertions, 26 deletions
diff --git a/Biz/Bild.nix b/Biz/Bild.nix
index 5a06595..ff525eb 100644
--- a/Biz/Bild.nix
+++ b/Biz/Bild.nix
@@ -21,7 +21,6 @@ rec {
haskellDeps = import ./Bild/Deps/Haskell.nix;
ghcWith = nixpkgs.haskell.packages.${constants.ghcCompiler}.ghcWithHoogle;
- #mkGhcjsPackageSet = nixpkgs.haskell.packages.${ghcjsCompiler}.ghcWithPackages;
sbclWith = nixpkgs.lispPackages_new.sbclWithPackages;
@@ -113,31 +112,6 @@ rec {
installPhase = "exit 0";
} // { env = ghc; };
- #ghcjs = main:
- # let
- # data = analyze main;
- # ghcjs = mkGhcjsPackageSet (hp: private.selectAttrs data.deps hp);
- # in stdenv.mkDerivation {
- # name = data.module;
- # src = ../.;
- # nativeBuildInputs = [ ghcjs ];
- # strictDeps = true;
- # buildPhase = ''
- # mkdir -p $out/static
- # # compile with ghcjs
- # ${ghcjs}/bin/ghcjs \
- # -Werror \
- # -i. \
- # --make ${main} \
- # -main-is ${data.module} \
- # -o ${data.out}
- # # optimize js output
- # ${nixpkgs.pkgs.closurecompiler}/bin/closure-compiler \
- # ${data.out}/all.js > $out/static/${data.out}
- # '';
- # installPhase = "exit 0";
- # } // { env = ghcjs; };
-
env = nixpkgs.pkgs.mkShell {
name = "bizdev";
# this should just be dev tools